Skip navigation

The plain HTTP request was sent to HTTPS port

If you get the above error on an ssl fastcgi phpMyAdmin Nginx set up its because you forgot to put the following line in you fastcgi parameters of your ssl nginx vhost:


fastcgi_param HTTPS on;

For more details look here at The plain HTTP request was sent to HTTPS port.

Advertisements

6 Comments

  1. That was helpful, thanks!

  2. try sqlyog which is an Open Source both for the ultra-competitive pricing and also free community edition and support when needed. my colleagues recommended this i am pretty much impressed with its feature & flexibility. simply rocks …just try

  3. Thanks, I would probably have found the solution myself, but not that fast! 🙂

  4. Thanks a lot! That was quite helpful to me too! I thought at first that PhpMyAdmin was goofing up!

  5. This is a Top Tip. Thanks very much. I too thought that I had done something wrong with my admin.

    I tried forcing SSL on PhpMyAdmin:

    $cfg[‘ForceSSL’] = true;

    but it gave me a loop!!

    Thank you very much!!

  6. Thanks! 🙂


One Trackback/Pingback

  1. […] example is phpmyadmin where this error can […]

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: